L1-022 奇偶分家 - java

L1-022 奇偶分家


时间限制
200 ms
内存限制
64 MB


题目描述:

给定N个正整数,请统计奇数和偶数各有多少个?

输入格式:
输入第一行给出一个正整N(≤1000);第2行给出N个非负整数,以空格分隔。

输出格式:
在一行中先后输出奇数的个数、偶数的个数。中间以1个空格分隔。

输入样例:
9
88 74 101 26 15 0 34 22 77
输出样例:
3 6


输出给定的n个数中 求出 奇偶个数分别有多少个


emmmmmmm

可以利用位运算 (x&1) == 1 判断是否为奇数
或者利用取余运算 (x%2) == 1 判断是否为奇数


位运算

import java.io.*;
import java.util.*;

public class Main
{

	public static void main(String[] args)
	{
		int n = sc.nextInt();

		int ji = 0, ou = 0;
		while (n-- > 0)
		{
			int x = sc.nextInt();
			if ((x & 1) == 1)
				ji++;
			else
				ou++;
		}
		out.println(ji + " " + ou);

		out.flush();
		out.close();
	}

	static Scanner sc = new Scanner(System.in);
	static PrintWriter out = new PrintWriter(System.out);
}

取余运算


import java.io.*;
import java.util.*;

public class Main
{

	public static void main(String[] args)
	{
		int n = sc.nextInt();

		int ji = 0, ou = 0;
		while (n-- > 0)
		{
			int x = sc.nextInt();
			if (x % 2 == 1)
				ji++;
			else
				ou++;
		}
		out.println(ji + " " + ou);

		out.flush();
		out.close();
	}

	static Scanner sc = new Scanner(System.in);
	static PrintWriter out = new PrintWriter(System.out);
}


位运算


如果有说错的 或者 不懂的 尽管提 嘻嘻

一起进步!!!


闪现

你可能感兴趣的:(pta,学习)